Deprecating/Supporting one platform version also deprecate/support other platform version

Description

When user add app version configs for platforms (Android & iOS) with same versions (E.g. 2.2.0) and deprecate/support one version but not the other. App also deprecate/support other platform version.

Scenario :
Add app version config lets say 2.5.0 for platform android and mark it as deprecated (by selecting expired date for the platform version). Add one more app version config lets say 2.5.0 for platform iOS (Supported). iOS app will not allow user to login showing 'Your version of the app is no longer supported. Update to the latest version to login.' Additionally, remove the entry from config for iOS and try logging in both platforms. Android and iOS both will allow user to login.

Steps to Reproduce

None

Reason for Variance

None

Release Notes

None

Assignee

Unassigned

Reporter

Mirza Mubashar Baig

Labels

None

Customer

None

URL

None

Groups with Read-Only Access

None

Actual Points

None

Reach

None

Impact

None

Open edX Discourse Thread

None

Platform Map Area (Levels 1 & 2)

None

Platform Map Area (Levels 3 & 4)

None

Contributor Name

None

Blended Project Status Page

None

edX Squad

None

Product Rollout Framework

None

Content & Partner Success Lead

None

Marketing Lead

None

Learning Lead

None

Support Lead

None

Priority

Unset