Android - Assessment - Switching to video mode in a subsection with no videos just shows an empty screen

Description

Switching to video mode in a subsection with no videos just shows an empty screen. It should probably show an empty message suggesting switching to full mode.

Steps to Reproduce

None

Reason for Variance

None

Release Notes

None

Activity

Show:
IbraheemZ
December 9, 2015, 1:27 PM
akivaR
November 16, 2015, 6:31 PM

Note that since the mode switcher icon changed, we changed the icon in the text as well.

Brian Guertin
November 16, 2015, 4:00 PM

What's the status of this? (it's marked "In progress" and assigned to you).

Do we need more information or clarification?

Mark Sadecki
July 6, 2015, 9:34 PM

If that's what the icon is supposed to represent, that works for me. The point I was trying to make is that the accessible text in the icon that appears in the warning must match the accessible text of the icon at the top of the view, otherwise it doesn't make sense. e.g. "To view other section content, select the Show Mode Switcher icon above and switch to full course mode." doesn't make sense if the screen reader user navigates to the button at the top of the view and finds that it is labelled "Video view" or something.

akivaR
July 6, 2015, 9:26 PM

To be clear, we can also do something more specific, just for the accessibility label if that's not good enough.

Done

Assignee

Mirza Mubashar Baig

Reporter

Mirza Mubashar Baig

Labels

Customer

None

URL

None

Groups with Read-Only Access

None

Actual Points

None

Reach

None

Impact

None

Open edX Discourse Thread

None

Platform Map Area (Levels 1 & 2)

None

Platform Map Area (Levels 3 & 4)

None

Contributor Name

None

Blended Project Status Page

None

edX Squad

None

Product Rollout Framework

None

Content & Partner Success Lead

None

Marketing Lead

None

Learning Lead

None

Support Lead

None

Story Points

1

Epic Link

Sprint

None

Fix versions

Priority

CAT-2