Juniper: Downgrade pycontracts to 1.8.12

Description

They seem to have removed 1.8.14 from pypi.

Cherrypick from https://github.com/edx/edx-platform/pull/24351

Assignee

Ned Batchelder

Reporter

Open Source Pull Request Bot

Contributor Name

Felipe Espinoza

Repo

edx/edx-platform

Customer

None

Epic Link

None

OSCM Assignee

None

Platform Map Area (Levels 1 & 2)

Developer Experiences

Platform Map Area (Levels 3 & 4)

None

Blended Hour Utilization Percentage

None

Priority

Unset
Configure