upgrade or deprecate pygments from the edx-platform

Description

Gemnasium shows one red dependency, and that is pygments.

It's only used in the paver command output, and there it's not even really needed as there is an alternative import (colorize) if it's not found.

Cleanup for the codebase:

  • Remove pygments in favor of something else that is used elsewhere, if that makes sense.

  • If it makes sense to keep it:

    • Move it down in base.txt or otherwise indicate that it's not a production dependency?

    • Update to the latest version

Note when pointing this story: pygments is also in the docs/shared/requirements.txt file, and I'm not sure what that file is for or what the implications are. There it's pinned to pygments==1.5, whereas in base.text it's pinned to pygments==2.0.1.

Reference: https://github.com/edx/edx-platform/search?utf8=%E2%9C%93&q=pygments

Steps to Reproduce

None

Current Behavior

None

Expected Behavior

None

Reason for Variance

None

Release Notes

None

User Impact Summary

None

Assignee

Unassigned

Reporter

JesseZ

Labels

Reach

None

Impact

None

Platform Area

None

Customer

None

Partner Manager

None

URL

None

Contributor Name

None

Groups with Read-Only Access

None

Actual Points

None

Category of Work

None

Platform Map Area (Levels 1 & 2)

None

Platform Map Area (Levels 3 & 4)

None

Story Points

2

Priority

Unset
Configure