Update Python Requirements for ECS containers

Description

Currently ECS containers are built based off a Docker image that gets updated on every merge to edx-platform. When PR tests run, we run pip install on boot-up, but only for the testing.txt file. So, when we have a PR upgrading dependencies, a lot of times our unittests won't actually run with the correct package versions installed. We need to fix this, to make sure we are pip installing any packages that have been upgraded.

Steps to Reproduce

None

Current Behavior

None

Expected Behavior

None

Reason for Variance

None

Release Notes

None

User Impact Summary

None

Activity

Show:
Stuart Young
June 11, 2019, 2:33 PM
Mike Youngstrom
March 7, 2019, 8:43 PM

This may be a dupe of TE‌-2861

Mike Youngstrom
March 7, 2019, 8:41 PM

Included in this should be the Django version

Done

Assignee

Unassigned

Reporter

Mike Youngstrom

Labels

None

Reach

None

Impact

None

Platform Area

None

Customer

None

Partner Manager

None

URL

None

Contributor Name

None

Groups with Read-Only Access

None

Actual Points

None

Category of Work

None

Platform Map Area (Levels 1 & 2)

None

Platform Map Area (Levels 3 & 4)

None

Story Points

2

Sprint

None

Priority

Unset