edx-analytics-dashboard Dependencies Support for Django 2.2

Versions in edx-analytics-dashboard already support Django 2.2

  • django-braces

  • django-countries

  • django-crispy-forms

  • django-debug-toolbar

  • django-dynamic-fixture

  • django-model-utils

  • django-soapbox

  • django-waffle

  • djangorestframework

  • drf-jwt

  • edx-auth-backends

  • edx-django-release-util

  • edx-django-utils

  • edx-drf-extensions (https://openedx.atlassian.net/browse/BOM-1045)

  • edx-i18n-tools

  • edx-opaque-keys

  • pytest-django

Support for Django 2.2 on master but not released to PyPI

  • django-appconf

  • social-auth-app-django

Haven't been tested with Django 2.2 upstream

  • django-webpack-loader

  • djangorestframework-csv

  • pinax-announcements

  • rest-condition (negligible Django usage beyond DRF, may just work with 2.2)