Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Toggle Enhancements

  • [RG]* (HIGH) Enhance BaseToggle with additional methods.

    • Add is_disabled (not is_enabled), is_on (is_enabled) and is_off (not is_enabled)

    • Makes a variety of conditions more readable when ENABLE_ or DISABLE_ are in the toggle name.

    • For example:

      • not DISABLE_SOME_FEATURE.is_enabled() # BEFORE; brain twister

      • DISABLE_SOME_FEATURE.is_off() # AFTER

    • This problem was discussed on Slack.

  • Replace or improve ExperimentWaffleFlag